Google pulling back support for its vital Applications

Google is taking away support of its several applications such as Google Maps, YouTube, Gmail and other applications from vast older android smartphones running on older Android operating systems offered by Google.

Smartphones that are currently running on Android 2.3.7 Gingerbread or older, won’t be able to use the services and products offered by Google. To continue using the services and apps, users least need to have Android 3.0 or greater to continue using applications. Due to privacy and security reasons and protecting user’s data.

Smartphones running on Android 2.3.7 or lower than that won’t be able to sign in and use Google apps and services after September 27, 2021. If you still using older Android OS, you can update on Android 3.0 or the latest OS offering from Google. With their latest and greatest advancements made by Google, Users can now enjoy a new interface that not just only look excellent but also, it’s built from the ground to provide the best stability and more ease of useability.

Categories: News